Regarding Log4J, the BSI warned of a significant security vulnerability on Friday (CVE-2021-44228). myOperations is also directly affected by using Apache Solr, our search and cache server. We therefore recommend installing a hotfix on the relevant systems until the officially fixed Solr version 8.11.1 of Apache is available.

To do this, please stop the Windows service “myOperations Apache Solr”.

Then please delete the files (the asterisk stands for any version number)

  • log4j-1.2-api-2. *. 1.jar
  • log4j-api-2. *. 1.jar
  • log4j-core-2. *. 1.jar
  • log4j-slf4j-impl-2.14.1.jar
  • log4j-web-2.14.1.jar

from the directory C:\Program Files\Axians\myOperations\solr\server\lib\ext and copy the new Log4J files * -2.16.0.jar (download either directly from the Log4j page or here) into this directory.

Then start the “myOperations Apache Solr” service again.